[Twisted-Python] twisted.enterprise.adbapi broken by loss of python-pgsql

exarkun at twistedmatrix.com exarkun at twistedmatrix.com
Mon Oct 17 13:47:49 EDT 2011

On 05:17 pm, peter.westlake at pobox.com wrote:
>The python-pgsql package, used by twisted.enterprise.adbapi to talk to
>PostgreSQL, has been removed from Debian:
>   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug%3D577664
>So far it has been removed from Unstable and Testing.

You can use psycopg or pygresql.  adbapi should work with any DB-API 2.0 
compliant module.

adbapi itself doesn't specifically depend on pgsql.  It requires the 
user to specify which module to use.

>Are there any plans to fix t.e.adbapi? Or perhaps replace it
>with txPostgres?
>   http://twistedmatrix.com/trac/ticket/4397

Probably not.  However, some people are interesting in a native Twisted 
implementation of the PostgreSQL protocol.  So it's /possible/ that will 
appear at some point.


More information about the Twisted-Python mailing list