[Twisted-Python] twisted.enterprise.adbapi broken by loss of python-pgsql

Peter Westlake peter.westlake at pobox.com
Mon Oct 17 18:16:40 EDT 2011

On Monday, October 17, 2011 5:47 PM, exarkun at twistedmatrix.com wrote:
> On 05:17 pm, peter.westlake at pobox.com wrote:
> >The python-pgsql package, used by twisted.enterprise.adbapi to talk to
> >PostgreSQL, has been removed from Debian:
> >
> >   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug%3D577664
> >
> >So far it has been removed from Unstable and Testing.
> You can use psycopg or pygresql.  adbapi should work with any DB-API 2.0 
> compliant module.
> adbapi itself doesn't specifically depend on pgsql.  It requires the 
> user to specify which module to use.

Oh, I see! I saw the error message coming from t.e.a and deduced,
wrongly, that it imported it directly! The fact that the Debian
python-twisted package doesn't depend on python-pgsql should
have given me a clue.

Thank you for the retroactive fix!


"Neutrinos travelling faster than light? I didn't see that coming!"

More information about the Twisted-Python mailing list