Changes between Version 61 and Version 62 of TwistedDevelopment


Ignore:
Timestamp:
04/18/14 10:39:15 (8 years ago)
Author:
Adi Roiban
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • TwistedDevelopment

    v61 v62  
    7676
    7777
     78== Runtime and development depenencies ==
     79
     80Important dependencies:
     81
     82 * zope.interface
     83
     84There are some additional optional dependencies:
     85
     86 * pycrypto and pyasn1 only need for Conch
     87 * pyobjc is required for cfreactor
     88 * pyopnessl for TLS support.
     89 * gmpy makes Conch a lot faster
     90 * pywin32 is required for process support on Windows
     91 * pyserial is required for serial ports
     92 * pygtk is required for the gtk class of reactors (or pygi or pygobject or something)
     93 * wxpython is required for wxsupport / wxreactor
     94 * gadfly, sqlite, pypgsql, psycopg, mysqldb, kinterbasdb (at least one) are required for twisted.enterprise.adbapi
     95 * SOAPpy is required for Twisted Web's SOAP support
     96 * pypam is required for twisted.cred PAM integration
     97
     98
     99And there are some additional development tools:
     100
     101 * subunit is required for trial's subunit output plugin
     102 * pyflakes is require to check code for common static errors
     103 * twistedchecker is required for automated coding standard compliance checks
     104 * pydoctor is required to generate the api documentation
     105 * sphinx is required to generate narative documentation
     106 * cython is required to update iocpreactor and some Failure unit tests
     107
     108
    78109== Tickets management ==
    79110