Opened 11 years ago

Closed 10 years ago

#993 defect closed fixed (fixed)

[PATCH] Excessive deprecation warnings from MetaInterface.__getattr__

Reported by: jknight Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: itamarst, jknight, srichter Branch:
Author:

Description


Attachments (1)

iface.diff (1.7 KB) - added by srichter 11 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by jknight

[19:00] <srichter> the problem is that hasattr(interface, 'im_class') 
produces a deprecation warning
[19:01] <srichter> and it shouldn't 

I agree, I think it should only print a deprecation warning if it's 
actually going to return a result. If it will raise AttributeError, it 
should not.

Changed 11 years ago by srichter

comment:2 Changed 11 years ago by srichter

Here is a patch that fixes the problem.

comment:3 Changed 10 years ago by exarkun

  • Component set to core
  • Resolution set to fixed
  • Status changed from new to closed

This code has been excised from trunk, the patch/issue is no longer relevant.

comment:4 Changed 6 years ago by <automation>

  • Owner itamarst deleted
Note: See TracTickets for help on using tickets.