Opened 3 years ago

Closed 3 years ago

#9139 defect closed fixed (fixed)

Handling unsupported user authentication keys

Reported by: the0id Owned by: Amber Brown (HawkOwl) <hawkowl@…>
Priority: high Milestone:
Component: conch Keywords:
Cc: Branch: 9139-the0id-handling-unsupported-keys
branch-diff, diff-cov, branch-cov, buildbot
Author:

Description

It looks like Twisted doesn't respond well when a client provides a public key for authentication that it doesn't support.

For example if a user offers an ed25519 key for authentication (something that OpenSSH will do automatically), Twisted throws an unhandled exception in keys.py line 174.

This does seem to be a bug, but because I'm surprised this hasn't been encountered before, even in my own testing, I would like someone to double check this to make sure I haven't missed something elsewhere.

Change History (4)

comment:1 Changed 3 years ago by Adi Roiban

Resolution: duplicate
Status: newclosed

I can confirm that I have also hit this bug.

Can you please share a traceback, to make sure we hit the same error.

But I think that this is a duplicate of #7946

comment:2 Changed 3 years ago by hawkowl

Resolution: duplicate
Status: closedreopened

I don't think this is a duplicate; this is more open-ended towards any kind of key we might not support.

comment:3 Changed 3 years ago by hawkowl

Branch: 9139-the0id-handling-unsupported-keys

comment:4 Changed 3 years ago by Amber Brown (HawkOwl) <hawkowl@…>

Owner: set to Amber Brown (HawkOwl) <hawkowl@…>
Resolution: fixed
Status: reopenedclosed

In 562496b:

Merge 9139-the0id-handling-unsupported-keys: Add graceful handling of unsupported keys in Conch server

Author: the0id
Reviewer: hawkowl
Fixes: ticket:9139

Note: See TracTickets for help on using tickets.