Opened 4 years ago

Closed 18 months ago

#8311 enhancement closed duplicate (duplicate)

Add DNS record types for DNSKEY and RRSIG

Reported by: Alex Gaynor Owned by: Alex Gaynor
Priority: normal Milestone:
Component: names Keywords:
Cc: Branch:
Author:

Description

Regardless of the low opinion I have of DNSSEC, it's useful to see these in an RR repr.

Attachments (1)

dnssec-names.diff (444 bytes) - added by Alex Gaynor 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by Alex Gaynor

Attachment: dnssec-names.diff added

comment:1 Changed 4 years ago by Alex Gaynor

Keywords: review added

comment:2 Changed 4 years ago by Adi Roiban

Keywords: review removed
Owner: set to Alex Gaynor

Many thanks for your contribution.

Can you please define the scope of your patch?

Is this targeted only for __repr__ ?

The patch needs at least one automated test to demonstrate the change and to prevent future regressions.

The patch also needs a NEWS file fragment (release notes fragment) as described here http://twistedmatrix.com/trac/wiki/ReviewProcess#Newsfiles

if this is useful for "production" usage, then the news fragment should describe how it can be useful... so that in the next release people are aware of this new thing :) ... it would be nice if the new thing is also documented so that people will know how to use this new nice thing :)

Please consider my comments and submit a new patch.

Thanks again!

comment:3 Changed 18 months ago by Adi Roiban

Resolution: duplicate
Status: newclosed

This looks like a duplicate for #4610

Note: See TracTickets for help on using tickets.