Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8216 release blocker: regression closed fixed (fixed)

strcred.py is missing from the Python3 installation

Reported by: doko Owned by: hawkowl
Priority: highest Milestone: Twisted 16.0
Component: core Keywords:
Cc: Branch: branches/strcred-dist3-8216
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description (last modified by Tristan Seligmann)

[reported at https://bugs.launchpad.net/bugs/1548972]

seen with 16.0.0pre1, calling the twistd script with Python3:

Unhandled Error
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/twisted/python/usage.py", line 447, in __str__
    return self.getSynopsis() + '\n' + self.getUsage(width=None)
  File "/usr/lib/python3/dist-packages/twisted/python/usage.py", line 483, in getUsage
    for (cmd, short, parser, desc) in self.subCommands:
  File "/usr/lib/python3/dist-packages/twisted/application/app.py", line 596, in subCommands
    for plug in sorted(plugins, key=attrgetter('tapname')):
  File "/usr/lib/python3/dist-packages/twisted/plugin.py", line 213, in getPlugins
    allDropins = getCache(package)
--- <exception caught here> ---
  File "/usr/lib/python3/dist-packages/twisted/plugin.py", line 171, in getCache
    provider = pluginModule.load()
  File "/usr/lib/python3/dist-packages/twisted/python/modules.py", line 389, in load
    return self.pathEntry.pythonPath.moduleLoader(self.name)
  File "/usr/lib/python3/dist-packages/twisted/python/reflect.py", line 303, in namedAny
    topLevelPackage = _importAndCheckStack(trialname)
  File "/usr/lib/python3/dist-packages/twisted/python/reflect.py", line 250, in _importAndCheckStack
    reraise(excValue, excTraceback)
  File "/usr/lib/python3/dist-packages/twisted/python/compat.py", line 412, in reraise
    raise exception.with_traceback(traceback)
  File "/usr/lib/python3/dist-packages/twisted/plugins/cred_sshkeys.py", line 15, in <module>
    from twisted.cred.strcred import ICheckerFactory
builtins.ImportError: No module named 'twisted.cred.strcred'

Change History (8)

comment:1 Changed 4 years ago by Tristan Seligmann

Description: modified (diff)

comment:2 Changed 4 years ago by Tristan Seligmann

Looks like the cred_sshkeys plugin was added to dist3 in #7998, but twisted.cred.strcred was not. I think this was an oversight?

comment:3 Changed 4 years ago by hawkowl

Milestone: Twisted 16.0
Priority: normalhighest

Yeah, this is an oversight, and a release blocker :((((((((((((((((((((((((

comment:4 Changed 4 years ago by hawkowl

Author: hawkowl
Branch: branches/strcred-dist3-8216

(In [46838]) Branching to strcred-dist3-8216.

comment:5 Changed 4 years ago by hawkowl

Keywords: review added

strcred wasn't actually ported, so we can't add it -- so, the easiest thing was to just port it.

Builders spun, all green. Please review.

comment:6 Changed 4 years ago by Tristan Seligmann

Keywords: review removed
Owner: set to hawkowl

Looks good, please merge.

comment:7 Changed 4 years ago by Tristan Seligmann

Resolution: fixed
Status: newclosed

(In [46842]) Merge strcred-dist3-8216: port twisted.cred.strcred to Python 3.

Fixes: #8216 Author: hawkowl Reviewer: mithrandi

comment:8 Changed 4 years ago by hawkowl

(In [46860]) Merge strcred-dist3-8216: port twisted.cred.strcred to Python 3.

Fixes: #8216 Author: hawkowl Reviewer: mithrandi

Note: See TracTickets for help on using tickets.