Opened 4 years ago

#8019 defect new

Under Win32 require deprecate win32api

Reported by: Vitold S Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Hello,

When I try to make simple Web-client under Twisted system try ot import too many packages.

Let's looking to this stacktrace:

`python Traceback (most recent call last):

File "p.py", line 7, in <module>

from twisted.web.client import Agent

File "C:\Python27\lib\site-packages\twisted\web\client.py", line 42, in <module>

from twisted.internet.endpoints import TCP4ClientEndpoint, SSL4ClientEndpoint

File "C:\Python27\lib\site-packages\twisted\internet\endpoints.py", line 44, in <module>

from twisted.internet.stdio import StandardIO, PipeAddress

File "C:\Python27\lib\site-packages\twisted\internet\stdio.py", line 28, in <module>

from twisted.internet import _win32stdio

File "C:\Python27\lib\site-packages\twisted\internet\_win32stdio.py", line 7, in <module>

import win32api

ImportError: No module named win32api `

We just try create Agent but system try import stdio from win32? I newer use this package in my code but it already get momory and try import deprecte package.

Another side of this problem that system require install package and in PIP there no exist.

Change History (0)

Note: See TracTickets for help on using tickets.