Opened 3 years ago

Closed 3 years ago

#7682 defect closed fixed (fixed)

Deprecate tap2deb and tap2rpm

Reported by: jMyles Owned by: hawkowl
Priority: normal Milestone:
Component: core Keywords:
Cc: Jean-Paul Calderone, Hynek Schlawack Branch: branches/deprecate-tap2whatever-7682
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl, jMyles

Description

tab2deb and tap2rpm are command-line utilities that create a shim over a .tap file, allowing it to be installed as an OS package (.deb or .rpm respectively).

Currently, a test (twisted.scripts.test.test_tap2deb.TestTap2DEB.test_basicOperation) fails in some situations, apparently because these utilities don't work properly in some specific OS configurations. For example, see https://twistedmatrix.com/trac/ticket/6920 (closed for other reasons).

It is not immediately obvious how widespread their use is, but exarkun advises deprecation. Another developer will need to weigh-in with a deprecation justification is one is to be provided.

Change History (6)

comment:1 Changed 3 years ago by Hynek Schlawack

Cc: Hynek Schlawack added
Milestone: Twisted 14.1.0

+1 on deprecation. They sound like they do something useful which they actually don’t and it keeps confusing the heck out of people.

I have removed the milestone since they are only for regressions.

comment:2 Changed 3 years ago by hawkowl

I think "we don't recommend their use" is good enough justification. Tools like fpm now exist which makes it not required.

comment:3 Changed 3 years ago by hawkowl

Author: jMyleshawkowl, jMyles
Branch: branches/deprecate-tap2whatever-7682

(In [44378]) Branching to deprecate-tap2whatever-7682.

comment:4 Changed 3 years ago by hawkowl

Keywords: review added

Let's deprecate this so we can remove it sooner rather than later.

Pushed up, builders spun, please review.

comment:5 Changed 3 years ago by Adi Roiban

Keywords: review removed
Owner: set to hawkowl

Changes looks good to merge. Thanks!

Just minor comment. I don't like this indentation as it requires tabs and then up to 3 extra spaces and backspaces...

+warnings.warn("tap2deb is deprecated since Twisted 15.2.",
+              category=DeprecationWarning, stacklevel=2)
+

I prefer

warnings.warn(
    "tap2deb is deprecated since Twisted 15.2.",
    category=DeprecationWarning, stacklevel=2)

comment:6 Changed 3 years ago by hawkowl

Resolution: fixed
Status: newclosed

(In [44447]) Merge deprecate-tap2whatever-7682: Deprecate tap2deb and tap2rpm

Author: hawkowl Reviewer: adiroiban Fixes: #7682

Note: See TracTickets for help on using tickets.