Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#7355 release blocker: regression closed fixed (fixed)

twisted.test.test_sslverify.SelectVerifyImplementationTests.test_dependencyMissingWarning fails on Python 3

Reported by: Jean-Paul Calderone Owned by: Glyph
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: branches/servid-error-7355
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description (last modified by Jean-Paul Calderone)

The formatting of import errors changed at some point. It used to be like:

No module named service_identity

On Python 3.3 it seems to be like:

import of 'service_identity' halted; None in sys.modules

The test is not equipped to handle this difference.

Attachments (1)

7355-1.diff (2.7 KB) - added by Adi Roiban 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:2 Changed 8 years ago by Adi Roiban

Owner: set to Adi Roiban
Status: newassigned

I will try to fix it now.

Changed 8 years ago by Adi Roiban

Attachment: 7355-1.diff added

comment:3 Changed 8 years ago by Adi Roiban

Keywords: review added
Owner: Adi Roiban deleted
Status: assignednew

I have fixed this with a separate value for python 3.

I moved the checks outside of with SetAsideModule("service_identity") to make it easier to see which is the ACT code and which CHECK code.

Thanks!

comment:4 Changed 7 years ago by Jean-Paul Calderone

#7535 was a duplicate of this.

comment:5 Changed 7 years ago by hawkowl

Owner: set to hawkowl

comment:6 Changed 7 years ago by hawkowl

Author: hawkowl
Branch: branches/servid-error-7355

(In [43022]) Branching to servid-error-7355.

comment:7 Changed 7 years ago by hawkowl

I have run this on the buildbots, but the 3.3 buildbot doesn't have OpenSSL and skips the tests. My local machine passes the test, but I'll wait for the buildbot to say so before merging.

comment:8 Changed 7 years ago by Jean-Paul Calderone

(In [43060]) Remove the duplication in the test for the warning message when service_identity is missing.

refs #7355

comment:9 Changed 7 years ago by Jean-Paul Calderone

(In [43061]) Python 2.6 compatibility

refs #7355

comment:10 Changed 7 years ago by Jean-Paul Calderone

I have run this on the buildbots, but the 3.3 buildbot doesn't have OpenSSL and skips the tests. My local machine passes the test, but I'll wait for the buildbot to say so before merging.

Probably necessary to draw more attention to the buildbot issue in order to get it resolved in a timely manner.

I posted https://twistedmatrix.com/pipermail/twisted-python/2014-September/028761.html to try to move this along.

comment:11 Changed 7 years ago by hawkowl

Hi exarkun, thanks for following up, and the cleanups (which I've checked over and +1, in case it needs it).

comment:12 Changed 7 years ago by Glyph

Keywords: review removed
Owner: changed from hawkowl to Glyph

Sorry this has taken so long to address; I've been dealing with a variety of buildbot issues and getting to the point where I could fix this took a little while.

That said, the buildbots are now fixed, I forced a build, and

L

G

T

M

Since I guess adi is half an author here I'll go ahead and land myself.

comment:13 Changed 7 years ago by Glyph

Resolution: fixed
Status: newclosed

(In [43180]) Merge servid-error-7355: Brief description

Author: exarkun, adiroiban

Reviewer: glyph

Fixes: #7355

Fix the Python 3 buildbots.

comment:14 Changed 6 years ago by hawkowl

Milestone: Twisted 14.1.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.