Opened 5 years ago

#7093 task new

forget about raw distutils support

Reported by: Glyph Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

I'm pretty sure you can't install, or possibly even import, zope.interface without setuptools. I can't even find a computer which doesn't have setuptools installed to try this with, because everywhere I have something running there is something which has a hard dependency on it.

There are also things that we can't do currently, like #7092, if we want backwards compatibility to raw distutils.

Let's just remove the cruft which I doubt anyone is really deploying with any more.

Change History (0)

Note: See TracTickets for help on using tickets.