Opened 6 years ago

Closed 6 years ago

#6827 defect closed wontfix (wontfix)

ImportError with daemonize

Reported by: Kevin Williams Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description (last modified by Jean-Paul Calderone)

I wonder if something with the latest release of Twisted may have broken Carbon (Graphite) installs. I've been struggling with this error:

>>> from twisted.scripts._twistd_unix import daemonize
ImportError: cannot import name daemonize

This happens even after:

pip install --upgrade daemonize

The same error has been posted to Graphite and Ubuntu forums.

Change History (3)

comment:1 Changed 6 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:2 Changed 6 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:3 Changed 6 years ago by Jean-Paul Calderone

Resolution: wontfix
Status: newclosed

twisted.scripts._twistd_unix is private (signified by the _ prefix on the module name).

Some refactoring took place that changed the internals of this module. Private modules provide no guarantee of API stability or backwards compatibility.

Sorry about the problem this introduces in Graphite. However, the problem is that Graphite uses private, internal Twisted APIs and expects them not to change.

Also note this is unrelated to the Python package named "daemonize". There happens to be some overlap in names used but it is coincidental.

Note: See TracTickets for help on using tickets.