Opened 4 years ago

Closed 3 years ago

#6626 enhancement closed fixed (fixed)

Remove all uses of deferredGenerator.

Reported by: Tom Prince Owned by: Tom Prince
Priority: normal Milestone:
Component: core Keywords:
Cc: Thijs Triemstra Branch: branches/remove-use-of-deferredGenerator-6626-2
branch-diff, diff-cov, branch-cov, buildbot
Author: tom.prince, tomprince

Description

This is a prerequisite of deprecating it in #6044.

All but one of the uses are in tests.

Change History (11)

comment:1 Changed 4 years ago by Tom Prince

Branch: branches/remove-use-of-deferredGenerator-6626

comment:2 Changed 4 years ago by Tom Prince

Keywords: review added
Owner: Tom Prince deleted

comment:3 Changed 4 years ago by Thijs Triemstra

Author: tom.prince
Cc: Thijs Triemstra added
Keywords: review removed
Owner: set to Tom Prince

Hi Tom,

found some more references.

./twisted/trial/util.py:314:_runSequentially = defer.deferredGenerator(_runSequentially)
./twisted/trial/test/test_runner.py:893:        test_spam = defer.deferredGenerator(test_bar)
./twisted/conch/test/test_manhole.py:281:    testControlD = defer.deferredGenerator(testControlD)
./twisted/conch/test/test_manhole.py:304:    testControlL = defer.deferredGenerator(testControlL)
./twisted/conch/test/test_manhole.py:359:    testDeferred = defer.deferredGenerator(testDeferred)
./twisted/test/test_newcred.py:16:from twisted.internet.defer import deferredGenerator as dG, waitForDeferred as wFD
./twisted/test/test_ftp.py:387:    testPASV = defer.deferredGenerator(testPASV)

They should be replaced as well no? (you manually set the branch so i hope im looking at the right one: remove-use-of-deferredGenerator-6626)

comment:4 Changed 4 years ago by Tom Prince

That looks like the list of changes I made in the branch. Looking at github, it looks like the correct one. (diffresource is confused, though)

comment:5 Changed 4 years ago by Tom Prince

Keywords: review added

comment:6 Changed 4 years ago by Thijs Triemstra

I clicked the (trac) log link at the top of this ticket and clicked view changes (this link) and it only shows changes in 2 files. So that link isn't reliable?

comment:7 Changed 4 years ago by Tom Prince

Owner: Tom Prince deleted

comment:8 Changed 4 years ago by Jean-Paul Calderone

(diffresource is confused, though)

The problem is the branch was made outside of the workflow and it's not obvious how to get the changes it contains. If you can, please re-create the branch following the standard workflow so that the normal expectations of developers and tools are satisfied.

comment:9 Changed 4 years ago by Tom Prince

Author: tom.princetom.prince, tomprince
Branch: branches/remove-use-of-deferredGenerator-6626branches/remove-use-of-deferredGenerator-6626-2

(In [39255]) Branching to remove-use-of-deferredGenerator-6626-2.

comment:10 Changed 4 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to Tom Prince

Thanks. These changes look good to me. Please merge.

comment:11 Changed 3 years ago by Tom Prince

Resolution: fixed
Status: newclosed

(In [42221]) Merge remove-use-of-deferredGenerator-6626-2: Remove all uses of deferredGenerator.

Author: tom.prince Reviewers: thijs, exarkun Fixes: #6626

Note: See TracTickets for help on using tickets.