Opened 7 years ago

Closed 6 years ago

#6353 task closed fixed (fixed)

Release Twisted 13.0

Reported by: therve Owned by: therve
Priority: normal Milestone:
Component: release management Keywords:
Cc: radix Branch: releases/release-13.0.0-6353
branch-diff, diff-cov, branch-cov, buildbot
Author:

Description

It'd be nice to have a release before the dreaded pycon sprints.

Change History (10)

comment:1 Changed 7 years ago by DefaultCC Plugin

Cc: radix added

comment:2 Changed 7 years ago by therve

Keywords: review added
Owner: therve deleted

comment:3 Changed 7 years ago by therve

Branch: releases/release-13.0.0-6353

comment:4 Changed 7 years ago by Glyph

Keywords: review removed
Owner: set to therve

Unfortunately there was a regression.

Other than that this branch looks like it is a worthwhile release branch.

I think you should cut a new branch, and issue a pre2; however, since the only issue here is a regression in the test suite, not application code, you should be able to do an accelerated cycle rather than an entire additional week.

Please submit for re-review when a new release branch is ready.

comment:5 Changed 7 years ago by therve

Keywords: review added
Owner: therve deleted

Alright, pre2 cut, revert included. The branch still conflicts about the quite file, but we have to deal with it manually I think.

comment:8 Changed 6 years ago by Glyph

Uh, never mind, apparently I can't force builds, because the bzr mirror (and therefore the build farm) can't see release branches? https://bugs.launchpad.net/twisted-trac-integration/+bug/1163438

comment:9 Changed 6 years ago by Glyph

Keywords: review removed
Owner: set to therve

Now that the aforementioned bug is fixed, builds look OK. I say: land it and ship it.

comment:10 Changed 6 years ago by therve

Resolution: fixed
Status: newclosed

(In [37924]) Merge release-13.0.0-6353

Author: therve Reviewer: glyph Fixes: #6353

Release Twisted 13.0.0

Note: See TracTickets for help on using tickets.