Opened 3 years ago

Closed 3 years ago

#6312 enhancement closed duplicate (duplicate)

Automatically detect the family and type of adopted sockets

Reported by: rwall Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

It might be possible to detect the type and family of adopted listening sockets.

This would simplify configuration and deployment with systemd. The type and family would only have to be specified once in the systemd configuration file. Currently you also have to specify the type and family again in the Twisted strports syntax. See:

  • source:trunk/doc/core/howto/systemd.xhtml

This nginx systemd patch seems to do this in C using some systemd provided library functions. sd_is_socket_inet and sd_is_socket_unix

I think this may have been discussed on IRC. There may even be an existing ticket (but I couldn't find it).

Change History (1)

comment:1 Changed 3 years ago by rwall

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5599.

Note: See TracTickets for help on using tickets.