Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6113 enhancement closed fixed (fixed)

twisted.web.test.test_http.Expect100ContinueServerTests depends on dictionary iteration order

Reported by: Jean-Paul Calderone Owned by: Jean-Paul Calderone
Priority: normal Milestone: Python 3.3 Minimal
Component: web Keywords: tests
Cc: jknight Branch: branches/continue-tests-better-6113
branch-diff, diff-cov, branch-cov, buildbot
Author: exarkun

Description

Iteration over items in a dictionary is unspecified and unstable. Expect100ContinueServerTests includes static strings which will only match actual output if dictionary iteration happens in a particular order. This makes them fragile tests. They should be changed not to depend on any particular order.

Change History (6)

comment:1 Changed 7 years ago by DefaultCC Plugin

Cc: jknight added

comment:2 Changed 7 years ago by Jean-Paul Calderone

Author: exarkun
Branch: branches/continue-tests-better-6113

(In [36172]) Branching to 'continue-tests-better-6113'

comment:3 Changed 7 years ago by Jean-Paul Calderone

Keywords: review added
Owner: changed from Jean-Paul Calderone to Itamar Turner-Trauring

Split off from #6110. Build results.

comment:4 Changed 7 years ago by Itamar Turner-Trauring

Keywords: review removed
Owner: changed from Itamar Turner-Trauring to Jean-Paul Calderone

Looks good, please merge.

comment:5 Changed 7 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

(In [36206]) Merge continue-tests-better-6113

Author: exarkun Reviewer: itamarst Fixes: #6113

Change the Twisted Web server tests for 100 Continue responses so that they do not depend on the particular ordering of headers in the response (thus making them not depend on dictionary iteration order which is unstable).

comment:6 Changed 7 years ago by Jean-Paul Calderone

#5757 was closed as a duplicate of this.

Note: See TracTickets for help on using tickets.