zope 3.6 now required but if you find that out at runtime you are in for a nasty surprise
|Reported by:||glyph||Owned by:||exarkun|
|Priority:||normal||Milestone:||Python 3.3 Minimal|
(github, patch, buildbot, log)
If you happen to have Zope Interface 3.5.1 - which, I should note, is the version included with just about every release of OS X people are now using, you get this error:
File ".../twisted/application/reactors.py", line 12, in <module> from twisted.plugin import IPlugin, getPlugins File ".../twisted/plugin.py", line 34, in <module> from twisted.python.modules import getModule File ".../twisted/python/modules.py", line 68, in <module> from twisted.python.filepath import FilePath, UnlistableError File ".../twisted/python/filepath.py", line 555, in <module> class FilePath(AbstractFilePath): File ".../zope/interface/declarations.py", line 495, in __call__ raise TypeError("Can't use implementer with classes. Use one of " TypeError: Can't use implementer with classes. Use one of the class-declaration functions instead.
It should instead say something like "You need Zope Interface at least 3.6 (but ideally earlier than 4.0 unless you want to see warnings...)" so the user knows what to fix.
Change History (22)
comment:14 Changed 4 years ago by exarkun
- Branch changed from branches/check-zi-version-5935 to branches/check-zi-version-5935-2
comment:21 Changed 4 years ago by glyph
- Keywords review removed
- Owner changed from glyph to exarkun
- Status changed from assigned to new