Opened 5 years ago

Closed 5 years ago

#5777 release blocker: regression closed fixed (fixed)

Conch tests are failing if PyCrypto or PyASN1 is not installed

Reported by: Alex Gaynor Owned by: Jean-Paul Calderone
Priority: highest Milestone:
Component: conch Keywords:
Cc: z3p Branch:
Author:

Description (last modified by Jean-Paul Calderone)

Currently (as of r34749 / #5776) they fail if you don't have either of these packages installed, in that case they should be skipped.

Attachments (1)

t5777-failing-tests.diff (710 bytes) - added by Alex Gaynor 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by DefaultCC Plugin

Cc: z3p added

Changed 5 years ago by Alex Gaynor

Attachment: t5777-failing-tests.diff added

comment:2 Changed 5 years ago by Alex Gaynor

Keywords: review added

comment:3 Changed 5 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:4 Changed 5 years ago by ralphm

Keywords: review removed
Owner: set to Alex Gaynor

This change looks good to me.

  • I'm ignoring the pyflakes warnings caused by the (unused) imports at the top that are there for the side effect of checking if the modules are there.
  • Nice typo fix.
  • When this is merged a news file needs to be added.

Please merge (with a news file).

comment:5 Changed 5 years ago by Jean-Paul Calderone

Owner: changed from Alex Gaynor to Jean-Paul Calderone
Status: newassigned

comment:6 Changed 5 years ago by Jean-Paul Calderone

Resolution: fixed
Status: assignedclosed

(In [34768]) Skip some Conch tests if dependencies are missing

Author: Alex Reviewer: ralphm Fixes: #5777

Note: See TracTickets for help on using tickets.