Changes between and of Version 9Version 10Ticket #5715


Ignore:
Timestamp:
05/26/2015 05:14:38 PM (5 years ago)
Author:
Thijs Triemstra
Comment:

add python < 2.6 stuff

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #5715 – Description

    v9 v10  
    1414twisted/web/_flatten.py:314:            # In Python 2.5, after an exception, a generator's gi_frame is
    1515}}}
     16
     17And everything around Python <= 2.6:
     18
     19{{{
     20twisted/__init__.py:16:    if version < (2, 6):
     21twisted/logger/_global.py:209:            if sys.version_info < (2, 6):
     22twisted/logger/test/test_flatten.py:149:            if sys.version_info[:2] == (2, 6):
     23twisted/python/zippath.py:21:if sys.version_info[:2] >= (2, 6):
     24twisted/test/test_log.py:261:        if sys.version_info >= (2, 6):
     25twisted/test/test_rebuild.py:195:    if sys.version_info < (2, 6):
     26twisted/test/test_rebuild.py:213:    if sys.version_info >= (2, 6):
     27twisted/test/test_twisted.py:194:    supportedPythonVersion = (2, 6)
     28twisted/test/test_twisted.py:640:if sys.version_info[:2] == (2, 6):
     29twisted/topfiles/setup.py:12:if sys.version_info < (2, 6):
     30twisted/topfiles/setup.py:40:if sys.version_info[:2] <= (2, 6):
     31twisted/trial/_synctest.py:243:        if sys.version_info[:2] > (2, 6):
     32twisted/internet/kqreactor.py:17:This implementation depends on Python 2.6 or higher which has kqueue support
     33twisted/topfiles/setup.py:13:    print >>sys.stderr, "You must use at least Python 2.6 for Twisted"
     34}}}