Opened 8 years ago

Last modified 7 years ago

#5683 defect new

— at zope.interface 4.0 causes DeprecationWarning for implements()Version 3

Reported by: Itamar Turner-Trauring Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Vladimir Perić, Thijs Triemstra Branch:
Author:

Description (last modified by Thijs Triemstra)

As mentioned in http://pypi.python.org/pypi/zope.interface/4.0.0, newer versions of zope.interface give deprecation warning for implements(), which is used widely by Twisted. This was done in order to support Python 3; the newer version is a class decorator.

As part of Python 3 support we should probably switch to the new style. It was added in zope.interface 3.6, in 2010, so switching completely doesn't seem like an issue: http://pypi.python.org/pypi/zope.interface/3.6.0#id5

Using class decorators shouldn't be a problem post-12.1, since we'll have dropped Python 2.5 support by then (#5553).

We should ensure Twisted mentions it requires zope.interface 3.6 in the appropriate places (import time, dependency documentation).

Change History (3)

comment:1 Changed 8 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

comment:2 Changed 8 years ago by Tristan Seligmann

This is still relevant for Python 3 support, but note that z.i 4.0.1 removed the DeprecationWarning again:

4.0.1 (2012-05-22)

Dropped explicit DeprecationWarnings for "class advice" APIS (these APIs are still deprecated under Python 2.x, and still raise an exception under Python 3.x, but no longer cause a warning to be emitted under Python 2.x).

comment:3 Changed 8 years ago by Thijs Triemstra

Description: modified (diff)
Note: See TracTickets for help on using tickets.