Opened 8 years ago

Last modified 7 years ago

#5683 defect new

— at zope.interface 4.0 causes DeprecationWarning for implements()Initial Version

Reported by: Itamar Turner-Trauring Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Vladimir Perić, Thijs Triemstra Branch:
Author:

Description

As mentioned in http://pypi.python.org/pypi/zope.interface/4.0.0, newer versions of zope.interface give deprecation warning for implements(), which is used widely by Twisted. This was done in order to support Python 3; the newer version is a class decorator.

As part of Python 3 support we should probably switch to the new style. It was added in zope.interface 3.6, in 2010, so switching completely doesn't seem like an issue: http://pypi.python.org/pypi/zope.interface/3.6.0#id5

Using class decorators shouldn't be a problem post-12.1, since we'll have dropped Python 2.5 support by then.

We should ensure Twisted mentions it requires zope.interface 3.6 in the appropriate places (import time, dependency documentation).

Change History (0)

Note: See TracTickets for help on using tickets.