Opened 8 years ago

Closed 3 years ago

#5515 defect closed fixed (fixed)

Error in DeprecationWarning with revision number (11.0.0+r33660)

Reported by: Thijs Triemstra Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description (last modified by Thijs Triemstra)

A recent trunk build shows this warning:

twisted.test.test_doc.DocCoverage.testPackages ...
[OK]/home/buildbot/twisted/slave.trunk/fedora11-64bit-py2.7/Twisted/twisted/python/reflect.py:374:
DeprecationWarning: twisted.persisted.journal was deprecated in twisted 11.0.0+r33660: Use a different persistence library. This one is no longer maintained.

The svn revision number here is incorrect (corresponds to trunk 12.1) and should read 'Twisted 11.0.0'.

The deprecation warning in [source:trunk/twisted/persisted/__init__.py] is defined like:

deprecate.deprecatedModuleAttribute(versions.Version('twisted', 11, 0, 0),
                                    "Use a different persistence library. This one "
                                    "is no longer maintained.",
                                    __name__, 'journal')

Only difference I see is versions.Version('twisted', 11, 0, 0) vs versions.Version('Twisted', 11, 0, 0) in other deprecations where 'Twisted' is capitalised.

Change History (2)

comment:1 Changed 8 years ago by Thijs Triemstra

Description: modified (diff)

comment:2 Changed 3 years ago by Craig Rodrigues

Resolution: fixed
Status: newclosed

This no longer occurs in newer versions of Twisted

Note: See TracTickets for help on using tickets.