Opened 18 years ago

Closed 10 years ago

Last modified 5 years ago

#546 defect closed invalid (invalid)

(maybe get rid of tap2deb) tap2deb fails on parsechangelog/debian

Reported by: acapnotic Owned by: Moshe Zadka
Priority: high Milestone:
Component: release management Keywords:
Cc: acapnotic, itamarst, Moshe Zadka, Thijs Triemstra, jesstess Branch:
Author:

Description


Change History (8)

comment:1 Changed 18 years ago by acapnotic

$ tap2deb -t telnet.tap
parsechangelog/debian: error: badly formatted trailer line, at changelog line 5
dpkg-buildpackage: unable to determine source package

comment:2 Changed 18 years ago by Glyph

Debian problem assigned to the obvious maintainer.

comment:3 Changed 17 years ago by radix

tap2deb hasn't been touched in a long time. moshez, either fix this, or find a
maintainer, or it's not going to be in Twisted 2.0 (it could have a separate
home apart from Twisted, of course).

comment:4 Changed 17 years ago by itamarst

The problem is you didn't pass the maintainer argument. I updated tap2deb to
require  it and to document the format. Leaving as bug since it should probably
enforce the correct format as well.

comment:5 Changed 16 years ago by Moshe Zadka

OK, I'm not sure what's going on here: Trying exactly what the instructions say, I get:

moshez@ceylon:~/src/twisted/Twisted$ ./bin/tap2deb -t telnet.tap
./bin/tap2deb: maintainer must be specified.

Trying the obvious thing:

moshez@ceylon:~/src/twisted/Twisted$ ./bin/tap2deb -t telnet.tap -m 'Moshe Zadka
 <moshez@divmod.com>' -u
dpkg-buildpackage: source package is twisted-telnet

Whole mess of warnings, yes, and then:

dpkg-buildpackage: full upload; Debian-native package (full source is included)
moshez@ceylon:~/src/twisted/Twisted$

Can anyone give reliable repro instructions which actually work?

comment:6 Changed 13 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

Close it when it can't be reproduced, especially when the reporter can't provide more info?

comment:7 Changed 10 years ago by jesstess

Cc: jesstess added
Resolution: invalid
Status: newclosed

Closing with an ack from keturn/acanoptic since we can't reproduce.

comment:8 Changed 5 years ago by Cory Benfield <lukasaoz@…>

In 8d927c9:

Error: Processor CommitTicketReference failed
 does not appear to be a Git repository. See the log for more information.
Note: See TracTickets for help on using tickets.