Opened 10 years ago

Closed 10 years ago

#5414 defect closed fixed (fixed)

CSS is not delivered with the right MIME type

Reported by: flox Owned by: flox
Priority: high Milestone:
Component: website Keywords:
Cc: oubiwann, Thijs Triemstra Branch:
Author:

Description (last modified by Thijs Triemstra)

The twisted trac seems to deploy CSS with the MIME type "text/html" instead of "text/css". Because of that, Firefox 8 and Chromium 11.10 refuse to load them and the website looks very distorted. I'm new to twisted and would very much like to learn about it, but reading the docs in some sort of 90s html makes me not want to.

CSS files that pop up in my error console:

Change History (4)

comment:1 Changed 10 years ago by DefaultCC Plugin

Cc: oubiwann added

comment:2 Changed 10 years ago by Jean-Paul Calderone

Owner: set to flox

This isn't trivially reproducable:

$ telnet twistedmatrix.com 80
Trying 66.35.39.65...
Connected to twistedmatrix.com.
Escape character is '^]'.
HEAD /trac/chrome/common/css/wiki.css HTTP/1.1
Host: twistedmatrix.com

HTTP/1.1 200 OK
Content-Length: 6029
Accept-Ranges: bytes
Server: TwistedWeb/11.0.0pre1
Last-Modified: Mon, 17 Oct 2011 17:26:38 GMT
Date: Sat, 26 Nov 2011 14:44:09 GMT
Content-Type: text/css

HEAD /trac/chrome/common/css/trac.css HTTP/1.1
Host: twistedmatrix.com

HTTP/1.1 200 OK
Content-Length: 16156
Accept-Ranges: bytes
Server: TwistedWeb/11.0.0pre1
Last-Modified: Mon, 17 Oct 2011 17:26:38 GMT
Date: Sat, 26 Nov 2011 14:44:29 GMT
Content-Type: text/css

HEAD /trac/chrome/common/css/ticket.css HTTP/1.1
Host: twistedmatrix.com

HTTP/1.1 200 OK
Content-Length: 3067
Accept-Ranges: bytes
Server: TwistedWeb/11.0.0pre1
Last-Modified: Mon, 17 Oct 2011 17:26:38 GMT
Date: Sat, 26 Nov 2011 14:44:40 GMT
Content-Type: text/css

HEAD /documents/current/core/howto/stylesheet.css HTTP/1.1
Host: twistedmatrix.com

HTTP/1.1 200 OK
Content-Length: 2210
Accept-Ranges: bytes
Server: TwistedWeb/11.0.0pre1
Last-Modified: Thu, 17 Nov 2011 16:14:02 GMT
Date: Sat, 26 Nov 2011 14:44:54 GMT
Content-Type: text/css

Can you investigate a little further? Thanks very much!

comment:3 Changed 10 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Description: modified (diff)

comment:4 Changed 10 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

This was caused by #4156. I upgraded the website deployment of Twisted to 11.1, the content-types are now correct. Thanks!

Note: See TracTickets for help on using tickets.