Opened 7 years ago

Closed 7 years ago

#4585 enhancement closed fixed (fixed)

Mark `t.i.process.Process` and `t.i.process.PTYProcess` as implementing IProcessTransport

Reported by: Screwtape Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: Branch: branches/process-interface-4585
branch-diff, diff-cov, branch-cov, buildbot
Author: exarkun

Description

Currently the IProcessTransport documentation claims that the only process transport in Twisted is for Win32, which is a total lie. t.i.process.Process and t.i.process.PTYProcess also implement it, and are very likely much more solid implementations.

We should mark both those classes as implementing that interface.

(this was filed once before as #4479, but that ticket got derailed into a different documentation issue)

Change History (9)

comment:1 Changed 7 years ago by Jean-Paul Calderone

#4648 was a duplicate of this.

comment:2 Changed 7 years ago by Jean-Paul Calderone

Author: exarkun
Branch: branches/process-interface-4585

(In [30045]) Branching to 'process-interface-4585'

comment:3 Changed 7 years ago by Jean-Paul Calderone

(In [30046]) Add a test verifying the process transport provides IProcessTransport

refs #4585

comment:4 Changed 7 years ago by Jean-Paul Calderone

(In [30047]) Make Process and PTYProcess implement IProcessTransport

refs #4585

comment:5 Changed 7 years ago by Jean-Paul Calderone

Keywords: review added
Owner: Glyph deleted

comment:6 Changed 7 years ago by Michael Hudson-Doyle

Keywords: review removed
Owner: set to Jean-Paul Calderone

test_process imports verifyObject and then doesn't use it.

I think "# Oh, the transport is available synchronously, how convenient." is a bit, um, sort of passive-aggressive or something. Can you make it a bit less snarky?

Fix these and land, please.

comment:7 Changed 7 years ago by Jean-Paul Calderone

(In [30127]) Remove unused import; adjust snarky comment

refs #4585

comment:8 Changed 7 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

(In [30128]) Merge process-interface-4585

Author: exarkun Reviewer: mwhudson Fixes: #4585

Declare that the POSIX process transports (for PTYs and non-PTYs) implement IProcessTransport.

comment:9 Changed 6 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.