Opened 12 years ago

Closed 11 years ago

#3974 enhancement closed duplicate (duplicate)

reader/writer interface docs incomplete

Reported by: Dave Peticolas Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: Thijs Triemstra Branch:
Author: davep

Description

The docstrings for addReader and addWriter in twisted.internet.interfaces don't mention that the reader/writer should implement ILoggingContext.

The docstrings for doRead and doWrite don't mention that the methods should return an exception if the connection has been closed.

The attached patch proposes some text.

Attachments (2)

twisted.patch (1.8 KB) - added by Dave Peticolas 12 years ago.
twisted.2.patch (1.1 KB) - added by Dave Peticolas 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by Dave Peticolas

Attachment: twisted.patch added

comment:1 Changed 12 years ago by Jean-Paul Calderone

#3980 was a duplicate of this.

comment:2 Changed 12 years ago by Dave Peticolas

Author: davep

Whoops, sorry for the dupe. I completely forgot I already submit it.

comment:3 Changed 12 years ago by Dave Peticolas

Ah, lordy, I just realized that IFileDescriptor inherits from ILoggingContext.

So that just leaves the extra docs for doRead and doWrite. Smoking too much crack lately.

Changed 12 years ago by Dave Peticolas

Attachment: twisted.2.patch added

comment:4 Changed 11 years ago by <automation>

Owner: Glyph deleted

comment:5 Changed 11 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Keywords: documentation review added

Looks like this should be up for review.

comment:6 Changed 11 years ago by Jean-Paul Calderone

Keywords: review removed
Resolution: duplicate
Status: newclosed

These docs were improved already in r31676 for #4539.

Note: See TracTickets for help on using tickets.