Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3705 defect closed duplicate (duplicate)

make trial compatible with python 2.7's test skipping

Reported by: benjamin Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:


Currently when the twisted test suite is run with the Python trunk, it skips every test. This is because 2.7's unittest module has a skip() method, and trial skips a test if a test case has a skip attribute. I suppose trial will just have to check to see if the skip attribute is a method.

This may just be a surface issue; I haven't looked deeper.

Change History (3)

comment:1 Changed 8 years ago by therve

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 8 years ago by therve

This is a duplicate of #3703.

comment:3 Changed 6 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.