Opened 8 years ago

Closed 8 years ago

#3703 defect closed fixed (fixed)

trial skips any test method when running against python trunk@HEAD

Reported by: Jean-Paul Calderone Owned by:
Priority: low Milestone: Python-2.7
Component: trial Keywords:
Cc: spiv, Benjamin Peterson Branch:
Author:

Description

Recently, stdlib unittest.TestCase had a feature for skipping tests added to it:

http://svn.python.org/view/python/trunk/Doc/library/unittest.rst?r1=70555&r2=70554&pathrev=70555

This gives all TestCases a skip attribute. trial interprets this to mean that all tests should be skipped now.

Change History (8)

comment:1 Changed 8 years ago by Jean-Paul Calderone

Milestone: Python-2.7

comment:2 Changed 8 years ago by spiv

Cc: spiv added

comment:3 Changed 8 years ago by therve

#3705 has been closed as a duplicate of this one.

comment:4 Changed 8 years ago by Benjamin Peterson

Cc: Benjamin Peterson added

comment:5 Changed 8 years ago by Glyph

I asked in the Python language summit today that this be fixed on Python's side of things; Guido seems fairly amenable. I'll go file a bug on the python tracker and link it here.

comment:6 Changed 8 years ago by Glyph

I've filed a Python bug here: http://bugs.python.org/issue5571

comment:7 Changed 8 years ago by Glyph

Resolution: fixed
Status: newclosed

Benjamin was kind enough to re-name the attribute. This is now fixed.

comment:8 Changed 6 years ago by <automation>

Owner: Jonathan Lange deleted
Note: See TracTickets for help on using tickets.