Opened 10 years ago

Closed 9 years ago

#3660 enhancement closed fixed (fixed)

IRCClient reports ":None:None" to CTCP version req

Reported by: CaptSolo Owned by: washort
Priority: highest Milestone:
Component: words Keywords: irc
Cc: Branch: branches/ctcp-version-3660-2
branch-diff, diff-cov, branch-cov, buildbot
Author: washort

Description

IRCClient responds to CTCP version requests if the "versionName" variable is set.

However, if variables "versionNum" and "versionEnv" are not set (documentation does not say they are mandatory, just says that they default to None) then text "None" is sent in the version reply:

CTCP VERSION reply from ...: versionName:None:None

Is that the intended behaviour? Would look better if they are omitted when None.

Change History (11)

comment:1 Changed 10 years ago by CaptSolo

Component: corewords
Owner: changed from Glyph to Jean-Paul Calderone

comment:2 Changed 10 years ago by washort

Keywords: review added
Owner: Jean-Paul Calderone deleted
Priority: normalhighest

comment:3 Changed 10 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to washort

Where's the code?

comment:4 Changed 10 years ago by Michael Hudson-Doyle

In branches/ctcp-version-3643 ?

comment:5 Changed 10 years ago by washort

Author: washort
Branch: branches/ctcp-version-3660

(In [26266]) Branching to 'ctcp-version-3660'

comment:6 Changed 10 years ago by Jean-Paul Calderone

Keywords: review added
Owner: washort deleted

comment:7 Changed 10 years ago by therve

Keywords: ctcp version review removed
Owner: set to washort

There is a small conflict with trunk apparently.

+            vstring = self.versionName

This variable looks unused.

Please merge once fixed!

comment:8 Changed 10 years ago by washort

Branch: branches/ctcp-version-3660branches/ctcp-version-3660-2

(In [26329]) Branching to 'ctcp-version-3660-2'

comment:9 Changed 10 years ago by Poincare

It doesn't matter what the answer if the vars needed aren't filled out because obviously the programmer doesn't care about the environment sent for CTCP requests.

comment:10 Changed 9 years ago by Jean-Paul Calderone

(In [28215]) Bump copyright date; add news file; adjust docstrings and assertions to match convention

refs #3660

comment:11 Changed 9 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

(In [28216]) Merge ctcp-version-3660-2

Author: washort Reviewer: therve Fixes: #3660

Fix IRCClient's VERSION responder to exclude version number and environment if versionNum or versionEnv is set to None.

Note: See TracTickets for help on using tickets.