Opened 15 years ago

Last modified 2 years ago

#341 defect closed fixed (fixed)

intermittent freebsd test_threads failure

Reported by: warner Owned by:
Priority: high Milestone:
Component: conch Keywords:
Cc: spiv, warner Branch:
Author:

Description


Change History (12)

comment:1 Changed 15 years ago by warner

I've seen this happen once, on the freebsd builder.

FAILURE: testCallInThread (twisted.test.test_threads.ThreadsTestCase)
-------------------------------------------------------------------------------
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/test/test_threads.py",
line 90, in testCallInThread
    self.fail("threads lost a count")
FailTest: threads lost a count

comment:2 Changed 15 years ago by Moshe Zadka

This has started to happen more:
http://twistedmatrix.com/buildbot/freebsd/events/793/summary
http://twistedmatrix.com/buildbot/freebsd/events/788/summary
http://twistedmatrix.com/buildbot/freebsd/events/758/summary
http://twistedmatrix.com/buildbot/freebsd/events/753/summary

That's four out of the ten I currently see in the buildbot, which means at
a 40% failure rate, it has started to be the #1 reason for freebsd
test failures. It would be nice if some freebsd guy managed to fix that.

comment:3 Changed 15 years ago by spiv

There's only one occurance on the current buildbot page:
    http://twistedmatrix.com/buildbot/freebsd/events/982/summary

(that's the *only* red box in the entire visible history, for all slaves!  Woohoo!)

comment:4 Changed 15 years ago by Moshe Zadka

So it's moved up to 100% :)
Seriously, can some fbsd guy look into this?

comment:5 Changed 15 years ago by spiv

Uh, that's one occurrence out of nine visible FreeBSD buildslave runs... that's
hardly 100% :)

But it certainly looks like a reproducible problem.

comment:6 Changed 15 years ago by Moshe Zadka

100% of reasons for fbsd failures? yes it is.

comment:7 Changed 15 years ago by spiv

Ah, I misunderstood you :)

comment:8 Changed 15 years ago by Moshe Zadka

I recently added more information to the failure.
Looks more like thread starvation rather than synchronization:
it has 642/1000, which would mean that it has race condition half
the time. OTOH, if we assume freebsd starved threads for a little
over five seconds, we would have a problem.
Another option is that it's not starvation but deadlock issues,
but this seems unlikely...

FAILURE: testCallInThread (twisted.test.test_threads.ThreadsTestCase)
-------------------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/trial/unittest.py", line
252, in _runPhase
    stage(*args, **kwargs)
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/trial/unittest.py", line
274, in _main
    self.runner(self.method)
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/trial/runner.py", line
102, in runTest
    method()
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/test/test_threads.py",
line 90, in testCallInThread
    self.fail("threads lost a count, index is %d "
  File "/home/slave/twisted/bsd-full2.2/Twisted/twisted/trial/unittest.py", line
98, in fail
    raise FailTest, message
FailTest: threads lost a count, index is 642  time is 1067501760.74, when is
1067501755.66

comment:9 Changed 14 years ago by Glyph

Are these still happening?

comment:10 Changed 14 years ago by Glyph

More than 6 months since I last asked, and nobody has re-reported.  I'm
resolving until someone decides to care about FreeBSD again.

comment:11 Changed 7 years ago by <automation>

Owner: spiv deleted

comment:12 Changed 2 years ago by GitHub <noreply@…>

In fa8f3cd:

Merge pull request #341 from twisted/8609-rodrigc-win

Author: rodrigc
Reviewer: markrwilliams
Fixes: #8609

Add _dumbwin32proc, _pollingfile, _win32stdio to fix importing on Python 3

Note: See TracTickets for help on using tickets.