Opened 10 years ago

Closed 10 years ago

#3203 release blocker: regression closed fixed (fixed)

PortableGtkReactor is broken

Reported by: jdahlin Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: branches/portablegtkreactor-3203-2
branch-diff, diff-cov, branch-cov, buildbot
Author: exarkun

Description

I get the following error when trying to use it on win32: AttributeError: 'PortableGtkReactor' object has no attribute '_simtag'

The workaround is to set self._simtag = None in the constructor.

Attachments (1)

3203-win.diff (948 bytes) - added by therve 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by jdahlin

Type: enhancementregression

comment:2 Changed 10 years ago by Jean-Paul Calderone

author: exarkun
Branch: branches/portablegtkreactor-3203

(In [23422]) Branching to 'portablegtkreactor-3203'

comment:3 Changed 10 years ago by Glyph

#3221 was a duplicate of this bug.

comment:4 Changed 10 years ago by Jean-Paul Calderone

The full test suite hangs when run against the branch. It gets to a test in flow and that's the end. Not sure what's up, and I don't have a Windows machine so debugging further will be more of a hassle for me than I'm likely to be willing to deal with.

comment:5 Changed 10 years ago by therve

Owner: changed from Glyph to therve

I'll try to look at it.

Changed 10 years ago by therve

Attachment: 3203-win.diff added

comment:6 Changed 10 years ago by therve

The attached patch fixes most problems I saw. There is still one problem with some tests succeeding after timeout (like LargeBufferTestCase.testWriter). But the rest looks good.

comment:7 Changed 10 years ago by therve

(In [23528]) Apply patch

Refs #3203

comment:8 Changed 10 years ago by therve

Keywords: review added
Owner: therve deleted

Please review.

comment:9 Changed 10 years ago by jdahlin

gtk.mainquit() is a leftover since PyGTK 0.6.x (gtk 1.2.x) and all references to it should probably be removed, since the module is called gtk2reactor after all.

comment:10 Changed 10 years ago by Jean-Paul Calderone

Branch: branches/portablegtkreactor-3203branches/portablegtkreactor-3203-2

(In [23689]) Branching to 'portablegtkreactor-3203-2'

comment:11 Changed 10 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to therve

Merged forward to make sure it passed at least as many tests on trunk, and it seems to. Change seems sensible to me, mostly mirroring what was done to the other gtk2reactor I guess. I guess we don't have any test coverage showing that gtk.mainquit() is doing anything. I dunno what versions of stuff anyone has or would expect to work. I'd be inlined to leave that code alone for a while longer, since all you did was indent it.

So, seems good to merge.

comment:12 Changed 10 years ago by therve

Resolution: fixed
Status: newclosed

(In [23696]) Merge portablegtkreactor-3203-2

Authors: therve, exarkun Reviewer: exarkun Fixes #3203

Fix PortableGtkReactor: we're now able to run trial test suite with the gtk2 reactor under Windows.

comment:13 Changed 7 years ago by <automation>

Owner: therve deleted
Note: See TracTickets for help on using tickets.