Change History (14)

comment:1 Changed 10 years ago by Glyph

Summary: Some links in the online documentation are brokenall API links in the online documentation are broken

I could have sworn this was already reported, but I can't find the duplicate. Updating the summary to be more descriptive instead.

comment:2 Changed 10 years ago by radix

You may have been thinking of #3130, which represents the code fix necessary to fix this issue.

comment:3 Changed 10 years ago by Jean-Paul Calderone

#3227 was a duplicate of this.

comment:4 Changed 10 years ago by collab

Cc: collab added
Keywords: documentation added
Priority: normalhigh

comment:5 Changed 10 years ago by Thijs Triemstra

Cc: Thijs Triemstra added; collab removed

What is the status of this ticket? The links are still broken here. How can we help?

comment:6 Changed 10 years ago by Thijs Triemstra

#1404 is related to this and probably a duplicate of this one (or vice versa).

comment:7 Changed 10 years ago by Thijs Triemstra

Priority: highhighest

comment:8 Changed 10 years ago by Jean-Paul Calderone

Cc: Jean-Paul Calderone added

There are three bugs described by this ticket.

  1. The initial API link to twisted.plugin used to be invalid, but no longer is, due to a mistaken in how the API documentation was generated. This part of the ticket is already resolved.
  2. The document contains API links to zope.interface. Lore does not support multi-project API link generation. The fix for this in the short term is probably to remove the API class from that link. In the long term, we might add this feature to Lore.
  3. The later API links which are broken are misspecified in the document and just need to be fixed by being made fully qualified or by the addition of a base attribute to the code tags.

The latter two should be very simple to resolve and the former is already fixed. #1404 isn't really a duplicate, as it is about linking to howto documentation in different subprojects which the plugin howto does not do.

comment:9 Changed 10 years ago by Thijs Triemstra

Owner: changed from oubiwann to Thijs Triemstra
Status: newassigned

comment:10 Changed 10 years ago by Thijs Triemstra

author: thijs
Branch: branches/api-links-broken-3177

(In [24643]) Branching to 'api-links-broken-3177'

comment:11 in reply to:  8 Changed 10 years ago by Thijs Triemstra

Keywords: review added
Owner: Thijs Triemstra deleted
Status: assignednew

Replying to exarkun:

The latter two should be very simple to resolve and the former is already fixed.

Think they're resolved in r24644, putting it up for review.

comment:12 Changed 10 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to Thijs Triemstra

I don't think there should be whitespace between <code> and IMaterial. It's probably harmless, but sometimes it can be a problem (it is in class="API" tags, at least). So better to just be consistent about whitespace everywhere, I think, even though it makes the paragraph margins ugly. :)

Other than that, looks good, please merge after the very minor whitespace issue is resolved.

comment:13 Changed 10 years ago by Thijs Triemstra

Summary: all API links in the online documentation are brokenSome links in the online documentation are broken

comment:14 Changed 10 years ago by Thijs Triemstra

Resolution: fixed
Status: newclosed

(In [24654]) Merge api-links-broken-3177: fix some broken api links in the plugin howto.

Author: thijs Reviewer: exarkun Fixes: #3177

Note: See TracTickets for help on using tickets.