Opened 14 years ago

Closed 13 years ago

#2869 defect closed fixed (fixed)

unclean reactor error from test_asynchronousException on OS X

Reported by: Jean-Paul Calderone Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Branch: branches/pbfailure-unclean-2869
branch-diff, diff-cov, branch-cov, buildbot
Author: therve

Description

=============================================================================== [ERROR]: twisted.test.test_pbfailure.PBFailureTestUnsafe.test_asynchronousException

Traceback (most recent call last): Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean. Selectables: <Broker #0 on 0>


Change History (9)

comment:1 Changed 13 years ago by therve

Owner: changed from Glyph to therve

comment:2 Changed 13 years ago by therve

author: therve
Branch: branches/pbfailure-unclean-2869

(In [23445]) Branching to 'pbfailure-unclean-2869'

comment:3 Changed 13 years ago by therve

(In [23446]) Keep track of the connection server-side and clean it up in tearDown

Refs #2869

comment:4 Changed 13 years ago by therve

Keywords: review added
Owner: therve deleted

All the tests in pbfailure could failed at some point. I think I fixes it in the branch, please review!

comment:5 Changed 13 years ago by therve

#2917 has been closed as a duplicate of this one.

comment:6 Changed 13 years ago by therve

Priority: highesthigh

comment:7 Changed 13 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to therve

Looks good, please merge.

comment:8 Changed 13 years ago by therve

Resolution: fixed
Status: newclosed

(In [23526]) Merge pbfailure-unclean-2869

Author: therve Reviewer: exarkun Fixes #2869

Remove some intermittent unclean errors in twisted.test.test_pbfailure where a server-side connection was left around.

comment:9 Changed 11 years ago by <automation>

Owner: therve deleted
Note: See TracTickets for help on using tickets.