Opened 16 years ago

Last modified 16 years ago

#251 defect closed fixed (fixed)

Twisted 1.0.7 build error on HP-UX

Reported by: rptownsend Owned by:
Priority: high Milestone:
Component: Keywords:
Cc: Jean-Paul Calderone, spiv, rptownsend Branch:
Author:

Description


Attachments (1)

dirent.h (8.3 KB) - added by rptownsend 16 years ago.

Download all attachments as: .zip

Change History (8)

Changed 16 years ago by rptownsend

Attachment: dirent.h added

comment:1 Changed 16 years ago by rptownsend

OS = HP-UX11i
Python = 2.3
While running 'python setup.py install' I get:

cc -Ae -DNDEBUG +O2 -z +Onofltacc +ESlit +Oentrysched 
+Odataprefetch +Onolimit +DAportable +z -
I/opt/python/include/python2.3 -c conftest.c -o conftest.o
cpp: "conftest.c", line 3: error 4062: _DIRENT_HAVE_D_TYPE 
is not defined

comment:2 Changed 16 years ago by itamarst

Looks like an issue with twisted.python.dir.

comment:3 Changed 16 years ago by itamarst

This error is just printed, yes? That's ok, it's just
checking to C if it's possible to compile a certain C
extension that is used as an optimization if available. If
build stage *fails*, that's a problem, but if it's just
printing this then it's fine.

comment:4 Changed 16 years ago by rptownsend

Yes, the message is just printed. Setup goes on to complete 
the installation.

comment:5 Changed 16 years ago by spiv

rptownsend: Also, try CVS.  I believe the cross-platform
support for t.p.dir has improved recently.

comment:6 Changed 16 years ago by itamarst

OK, since it's only printed, it's not a bug, merely messy
output, so I'm marking this closed. I added a little
informative message in setup.py to clarify this.

comment:7 Changed 8 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.