Opened 15 years ago

Closed 14 years ago

#2448 defect closed fixed (fixed)

deferToThread w/ trial -u times out on second pass

Reported by: mwl Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: therve Branch:
Author:

Description

Testing code containing deferToThread fails (by timing out) on the second pass when running with trial -u

This code demonstrates the problem:

from twisted.trial import unittest
from twisted.internet.threads import deferToThread
 
from time import sleep
 
def blockingFunc():
     sleep(0.1)

class DeferToThreadTestCase(unittest.TestCase):

     def testDeferToThread(self):
         return deferToThread(blockingFunc)

Link to original discussion on Twisted-Python

Change History (4)

comment:1 Changed 15 years ago by therve

#2568 was a duplicate of this one.

comment:2 Changed 15 years ago by therve

Cc: therve added

comment:3 Changed 14 years ago by therve

Resolution: fixed
Status: newclosed

It has been solved bu #1832 in r20103.

comment:4 Changed 11 years ago by <automation>

Owner: Jonathan Lange deleted
Note: See TracTickets for help on using tickets.