Opened 15 years ago

Closed 15 years ago

#2152 defect closed invalid (invalid)

web2 dependency issue in svn trunk

Reported by: rikyu Owned by: rikyu
Priority: normal Milestone:
Component: release management Keywords:
Cc: Jean-Paul Calderone, rikyu Branch:
Author:

Description

as of source:/trunk@18388

I recently updated my SVN copy of Twisted, and went to install it, but ran into a weird little dependency.

Since I intended to install it normally, rather than run directly out of the working directory, I followed the standard procedure, and installed all the packages.

However, it seems that one of the twistd plugins has a dependency on web2, so I wasn't able to use twistd until I added web2 to the project list in setup.py and reinstalled.

I'm not sure exactly where web2 is the the whole scheme of things, so perhaps this omission was intentional. I know most non-developers probably don't run out of SVN trunk, so I figured it might have been overlooked.

Change History (2)

comment:1 Changed 15 years ago by Jean-Paul Calderone

Cc: Jean-Paul Calderone rikyu added
Owner: changed from radix to rikyu

Could you explain why you couldn't use twistd? I suspect you saw a traceback from the twisted_web2.py plugin which was /not/ installed trying to import twisted.web2 which was /also/ not installed and so printed a traceback, but didn't actually prevent twistd from working properly.

If this is the case, I think this is a known issue with the plugin system, but one which does not actually prevent twistd from being used, even though it prints a traceback.

If not, please provide more information about the failure.

comment:2 Changed 15 years ago by rikyu

Resolution: invalid
Status: newclosed

Embarrassingly enough, I can't reproduce the error now to get the traceback. I'm inclined to think you're right, that this wasn't actually stopping me from using twistd; I believe this was actually caused by bugs in my code, but I jumped to conclusions upon seeing the traceback.

Note: See TracTickets for help on using tickets.