Opened 13 years ago

Closed 8 years ago

#1589 defect closed fixed (fixed)

cftp.py fails to transfer files

Reported by: jaze Owned by: jaze
Priority: normal Milestone:
Component: conch Keywords:
Cc: spiv, Jean-Paul Calderone Branch:
Author:

Description

Unhandled error in Deferred:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 292, i                                                                                                    n unpause
    self._runCallbacks()
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 328, i                                                                                                    n _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 296, i                                                                                                    n _continue
    self.unpause()
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 292, i                                                                                                    n unpause
    self._runCallbacks()
--- <exception caught here> ---
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 328, i                                                                                                    n _runCallbacks
    self.result = callback(self.result, *args, **kw)
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 296, i                                                                                                    n _continue
    self.unpause()
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 292, i                                                                                                    n unpause
    self._runCallbacks()
  File "/usr/lib/python2.4/site-packages/twisted/internet/defer.py", line 345, i                                                                                                    n _runCallbacks
    self.result.cleanFailure()
  File "/usr/lib/python2.4/site-packages/twisted/python/failure.py", line 297, i                                                                                                    n cleanFailure
    self.__dict__ = self.__getstate__()
  File "/usr/lib/python2.4/site-packages/twisted/python/failure.py", line 283, i                                                                                                    n __getstate__
    c['stack'] = [
  File "/usr/lib/python2.4/site-packages/twisted/python/reflect.py", line 448, i                                                                                                    n safe_repr
    failure.Failure().printTraceback(file=io)
  File "/usr/lib/python2.4/site-packages/twisted/python/failure.py", line 171, i                                                                                                    n __init__
    stack.insert(0, [
  File "/usr/lib/python2.4/site-packages/twisted/internet/base.py", line 331, in                                                                                                     sigInt
    log.msg("Received SIGINT, shutting down.")
  File "<twisted.python.hook (macro)>", line 8, in msg

  File "/usr/lib/python2.4/site-packages/twisted/python/threadable.py", line 182                                                                                                    , in _synchPre
    self._threadable_lock.acquire()
exceptions.RuntimeError: maximum recursion depth exceeded

Change History (3)

comment:1 Changed 13 years ago by spiv

Cc: spiv added

comment:2 Changed 10 years ago by Jean-Paul Calderone

Cc: Jean-Paul Calderone added
Owner: changed from z3p to jaze
Type: enhancementdefect

jaze, can you explain how or when this happens? Best would be if you could provide a minimal self-contained example which produces the behavior or a unit test which does so.

comment:3 Changed 8 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

#3927 was a duplicate of this.

Also, with #411 resolved, this should be fixed.

Note: See TracTickets for help on using tickets.