Opened 13 years ago

Closed 8 years ago

#1549 task closed wontfix (wontfix)

Add twisted.web2.xmlrpc docs and example code.

Reported by: oubiwann Owned by:
Priority: normal Milestone: Web2-Gold-Master
Component: web2 Keywords: xmlrpc docs demos examlpes
Cc: itamarst, jknight, oubiwann, David Reid, Thijs Triemstra Branch: branches/xmlrpc-docs-1549
branch-diff, diff-cov, branch-cov, buildbot
Author: oubiwann

Description

Itamar's XML-RPC code is going into web2 any day now, and it will need some docs. I've started putting some together, and when I'm done, will have them reviewed for inclusion.

Attachments (1)

xmlrpc.html (44.4 KB) - added by oubiwann 12 years ago.
First draft of t.w2.xmlrpc howto

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by itamarst

I hope you're basing them on the twisted.web xmlrpc docs? Less work.

comment:2 Changed 13 years ago by oubiwann

Status: newassigned

Yes, I've copied them over and have started updating them :-)

As for the format: James, is there an automated process that will get buggered if I keep the old format of xhtml? Are the ReST docs going away? Or should I convert the xhtml to ReST?

comment:3 Changed 13 years ago by oubiwann

I finally got a chance to start this tonight (at hacking society) and it's going smoothly. I have some suggestions, though:

1) ditch the .rpy listing

2) replace it with a similar example, showing the Quoter as a resource in a web2 server example -- putChild('RPC2', Quoter())

3) ditch the SOAP example listing

4) ditch the SOAP + XML-RPC example (as the new example above will show this basic functionality)

Later (when http-auth-1475 gets merged):

5) write a cred/auth example

Thoughts?

comment:4 Changed 13 years ago by itamarst

Sounds good to me.

comment:5 Changed 13 years ago by oubiwann

Just talked with James on IRC about formatting, etc.:

1) I'm going to convert to ReST

2) All the inline code will be moved into "examples"

3) this file will be named xmlrpc-howto.txt

comment:6 Changed 13 years ago by itamarst

ReST is not well supported by our current website integration infrastrcture; notice how web2 documentation link on site is broken...

comment:7 Changed 13 years ago by oubiwann

Here's a related ticket, regarding Itamar's last comment:

#1515 - Web2 documentation should not disregard the Documentation Standard

In the comment from 03/15/06 15:51:56, dreid outlines a process, but on IRC he just said that this has not been decided as yet.

Regardless, I will continue work on the howto. For now, I will keep it in xhtml since it will be easier to convert from that to ReST than from ReST back to xhtml. I will wait on the patch until the doc format has reached some sort of conclusion.

comment:8 Changed 12 years ago by oubiwann

Ticket for the http auth branch: #1475

comment:9 Changed 12 years ago by oubiwann

Cc: David Reid added

comment:10 Changed 12 years ago by oubiwann

I have the howto updated for twisted.web2 now, with the exception of a client (Proxy) example and an authentication example. I have opend ticket #1895 for writing the client code. Unless asked to do otherwise, I will submit the docs for #1549 when #1895 is closed and the Proxy patch is in trunk.

Changed 12 years ago by oubiwann

Attachment: xmlrpc.html added

First draft of t.w2.xmlrpc howto

comment:11 Changed 12 years ago by oubiwann

I've added a first draft of the docs, so that the content can be reviewed. I've attached the HTML as generated by admin/process-docs, since the listings can be viewed easily with a single upload.

The only section I haven't worked on yet is the client section. It should be essentially identical to the old section, but for the sake of completeness, I am waiting to resolve the issues I am having with the new proxy code (#1895) first.

comment:12 Changed 12 years ago by oubiwann

Milestone: Web2-Gold-Master

comment:13 Changed 10 years ago by Jean-Paul Calderone

The attached file is lore output. Is it too much to hope that you still have the lore input from which this was generated?

Whatever the case, we should adjust the document to cover twisted.web.xmlrpc instead.

comment:14 Changed 10 years ago by oubiwann

I do believe it still exists on one of my laptops... yes, I have just confirmed that I kept it in an old checkout of Twisted (r17451):-)

I will update this ticket with a branch that contains the files (and then later update those files to use web instead of web2).

comment:15 Changed 10 years ago by oubiwann

author: oubiwann
Branch: branches/xmlrpc-docs-1549

(In [24911]) Branching to 'xmlrpc-docs-1549'

comment:16 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

Can this be moved to web instead, since web2 is being deprecated, or should this ticket simply be closed?

comment:17 Changed 9 years ago by Jean-Paul Calderone

Twisted Web has some XML-RPC docs already. Maybe someone could take a look at the branch here and decide if any of the docs represent improvements which could be ported back to Twisted Web.

I don't think there's a whole lot of value in finishing the web2 docs, but I'm not going to stop anyone from doing it either.

comment:18 Changed 8 years ago by <automation>

Owner: oubiwann deleted

comment:19 Changed 8 years ago by washort

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.