Opened 16 years ago

Last modified 16 years ago

#1494 defect closed invalid (invalid)

Memory leak using example web server?

Reported by: chileverde Owned by:
Priority: highest Milestone:
Component: Keywords:
Cc: spiv, chileverde Branch:
Author:

Description


Change History (3)

comment:1 Changed 16 years ago by chileverde

It seems there is a mem leak somewhere. When I start the attached server with:     
twistd -y server.py     
is uses around 7mb of mem, but then I run:     
ab -n10000 -c4 http://host:8080/    (from a different pc of course) 
and memory starts getting used. When it finishes running, the memory is still     
used up to (96% of 128 mb), and it doesn't free up until I kill the twisted     
process.     
     
System:  
Ubuntu 2.6.10-5-386 
Python 2.4.1 (#2, Mar 30 2005, 21:51:10) 
[GCC 3.3.5 (Debian 1:3.3.5-8ubuntu2)] on linux2 
 
Please let me know if I can help in any way.

comment:2 Changed 16 years ago by spiv

Rejecting; this is a duplicate of issue 1495.

comment:3 Changed 11 years ago by <automation>

Note: See TracTickets for help on using tickets.