Opened 16 years ago

Closed 16 years ago

#1365 defect closed wontfix (wontfix)

select.error: (10022, 'Windows Error 0x2726')

Reported by: ghazel Owned by:
Priority: high Milestone:
Component: core Keywords: win32
Cc: justinj, ghazel, teratorn Branch:
Author:

Description


Change History (7)

comment:1 Changed 16 years ago by ghazel

Weird error, Win98SE, selectreactor:

  File "twisted\internet\posixbase.pyc", line 206, in run
    
  File "twisted\internet\posixbase.pyc", line 214, in mainLoop
    
--- <exception caught here> ---
  File "twisted\internet\base.pyc", line 541, in runUntilCurrent
    
  File "twisted\internet\tcp.pyc", line 489, in resolveAddress
    
  File "twisted\internet\tcp.pyc", line 496, in _setRealAddress
    
  File "twisted\internet\tcp.pyc", line 511, in doConnect
    
select.error: (10022, 'Windows Error 0x2726')

comment:2 Changed 16 years ago by teratorn

Cc: teratorn added

Is this reproduceable on Win2K or above? Can you provide sample code that demonstrates the problem? Under what conditions does this occur? Any other details?

comment:3 Changed 16 years ago by ghazel

Never seen it on win2k and up, no reproduction code.

comment:4 Changed 16 years ago by teratorn

Are you still running the code that this occured in originally? How often does it happen?

comment:5 Changed 16 years ago by ghazel

Yeah, I still distribute the code where that error occured. It's rare, though.

comment:6 Changed 16 years ago by teratorn

Resolution: wontfix
Status: newclosed

As far as I am concerned, Win2K and above are the only officially supported platforms.

We would need some way to reproduce this problem, even intermittently, to have any chance of figuring it out.

With this in mind I'm going to close the ticket. If anyone cares to pursue this further see below.

It seems the error number 10022 is WSAEINVAL (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/winsock/winsock/windows_sockets_error_codes_2.asp):

Invalid argument.
Some invalid argument was supplied (for example, specifying an invalid level to the setsockopt function). In some instances, it also refers to the current state of the socket, for instance, calling accept on a socket that is not listening.

I assume that Python is getting this error number from a call to getsockopt() with a optname of SO_ERROR, or (unlikely) a call to WSAGetLastError().

Maybe the problem is, as the error description suggests, that Twisted is calling connect() on a disconnected socket. Well that's all I've got. I will leave it up to any interested parties to pursue this further (and reopen the ticket, if so).

comment:7 Changed 11 years ago by <automation>

Owner: justinj deleted
Note: See TracTickets for help on using tickets.