Opened 8 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#10256 defect closed duplicate (duplicate)

Can't find domain with only AAAA records (no A records)

Reported by: xfk Owned by:
Priority: normal Milestone:
Component: names Keywords:
Cc: Branch:
Author:

Description (last modified by xfk)

A tcpdump shows that twisted only sends A? requests before throwing a DNS lookup error.

With adding IPv6Address in the list on the following line twisted also looks for AAAA records and successfully finds them: https://github.com/twisted/twisted/blob/trunk/src/twisted/internet/_resolver.py#L305

Altough it finds the the correct AAAA record is found with the modification above (looking at tcpdump), it never tries to connect to the returned address and only giving the following error: An error occurred while connecting: -9: Unknown error -9.

Related: https://github.com/matrix-org/synapse/issues/10694

Change History (5)

comment:1 Changed 8 weeks ago by xfk

Description: modified (diff)

comment:2 Changed 8 weeks ago by xfk

Description: modified (diff)

comment:3 Changed 7 weeks ago by Glyph

What you really want to be doing here is using HostnameEndpoint rather than calling this directly.

comment:4 Changed 7 weeks ago by Tom Most

Component: corenames
Resolution: duplicate
Status: newclosed

This is a duplicate of #10062. There is a PR associated with #10062 (PR #1488) though it seems to have stalled out --- a fresh attempt would be welcome.

Last edited 7 weeks ago by Tom Most (previous) (diff)

comment:5 Changed 7 weeks ago by Richard van der Hoff

Tom, are you sure this is a duplicate of #10062? My reading is that #10062 is complaining about the use of ANY? lookups, while this one refers to a different bit of code, which doesn't do ANY? lookups (but also doesn't do AAAA? lookups).

Note: See TracTickets for help on using tickets.