[Twisted-Python] strange exception on Python 2.6 + Snow Leopard

Phil Christensen phil at bubblehouse.org
Mon Aug 31 16:40:39 EDT 2009

On Aug 31, 2009, at 3:47 PM, Steve Steiner (listsin) wrote:
> On Aug 31, 2009, at 3:36 PM, Phil Christensen wrote:
>> hey all,
>> I just upgraded to Mac OS X 10.6 which includes Python 2.6.1. I'm
>> running the latest SVN HEAD of Twisted, but when I run twistd I get  
>> an
>> exception before it continues working (apparently) normally. Here's
>> what I'm seeing:
>> thrawn:~ phil$ twistd
>> Traceback (most recent call last):
>>  File "/Users/phil/Workspace/Twisted/twisted/python/reflect.py",
>> line 473, in namedAny
>>    obj = getattr(obj, n)
>> exceptions.AttributeError: 'module' object has no attribute  
>> 'ssl_test'
>> [continues to print usage info]
>> I've deleted all my dropin.cache files, and grepped through my source
>> and Twisted's for a reference to 'ssl_test', but to no avail.
>> Like I said, it doesn't appear to be a fatal exception, but I'd like
>> to make it go away. Any ideas?
> I saw this too.  It has to do with the plugin cache directory not
> being writable; there's a bug filed on it on the Twisted Trac.  I
> ended up modifying the library code to get rid of it; the file to
> change is the one in the error message and the fix is listed in the
> bug in the Twisted Trac instance.

Hmm, sorry to question, but are you sure?

I only ask because I'm fairly certain all my plugin directories  
(including Twisted's) are all writeable. I run them out of the SVN  
checkout in my home dir, using egg-/symlinks

AFAIK, the error you're referring to is mentioned in this ticket, and  
possibly others:


and also this FAQ entry:


which is a distinctly different exception, 'permission  
denied' (IOError, I think).


More information about the Twisted-Python mailing list