[Twisted-Python] trial (unit test) naming convention or obligation?
mailing_lists at evotex.ch
Fri Mar 7 08:44:54 EST 2008
I am starting to use the trial package and while looking at some
examples I saw that some methods start with "test_" and some don't, so I
thought the test cases must start with that, then I noticed in another
file that camelCase was used, so what would have been "test_basic_op" in
one file would be "testBasicOp" in another. I just want to be sure as I
couldn't find any documentation other than "look at the code" (which I
have), and since I never actually found the parser : if a method starts
(contains it at the beginning) with the word "test", then the test suite
will execute it, if not, then it won't, correct?
More information about the Twisted-Python