[Twisted-Python] client, deferred and/or reactor hung on these 2 URL's

Eric Mangold teratorn at twistedmatrix.com
Mon Jan 15 00:01:42 MST 2007

On Sun, 14 Jan 2007 23:12:55 -0600, Rick Graves <gravesricharde at yahoo.com>  

> Eric,
> I ran wget on the 2 URL's, and what I got may lead to
> the root cause of the problem.
> Here is the end of what appeared in the terminal
> window:
> I assume this is a case of endless loop redirection.
> I got this for both URL's.  The complete transcript
> for both is here:
> http://www.advanced-app.com.hk/MiscJunk/wget.txt
> I am running kubuntu, "codenamed 'Dapper Drake'" ver.
> 6.06.  For this version, I get ethereal not WireShark.
> I installed ethereal before running wget, but I am
> wondering whether wget might zero in on the problem.So I hope to find  
> out before spending some time trying
> to figure ethereal out. Also, I have ADSL service from different ISP's  
> at home
> and at the office.  These two URL's hang for me at the
> office, but work OK for me at home.  (They would be
> going through different ISP's and different proxies.)
>I have not filed a bug report yet.  If the wget output
> does in fact zero in on the problem, I will do so
> right away.

It definitely seems that your ISP is at fault. I just tried the URL with  
the addition of "/link.php" and that works fine, too. The fact that you  
can demonstrate the problem on one ISP but not the other makes the case  
pretty clear.

This, however, raises the question of whether downloadPage and friends  
ought to support a redirection limit, and whether such a limit should be  
set by default. In anyone actually wants to discuss this please start a  
new thread on the Twisted Web mailing list.

Eric Mangold
Twisted/Win32 Co-Maintainer

More information about the Twisted-Python mailing list