[Twisted-Python] cgi on win32 fails, process only available in this reactor on POSIX

eltronic at juno.com eltronic at juno.com
Wed Jul 2 21:37:52 EDT 2003

am I missing something to get cgi working?
running a web.tas created from a dos window,
when I navigate to http://localhost/moin.cgi

**edited [HTTPChannel,0,] Traceback 
File "...\twisted\web\twcgi.py", line 130, in runProcess
   reactor.spawnProcess(p, self.filename, [self.filename]+qargs, env,
File "...\twisted\internet\default.py", line 168, in spawnProcess
   raise NotImplementedError, "process only available in this reactor on

judging from the one paragraph in book.pdf on cgi
I'm guessing its not a huge priority to have this 
work on win98 out of the box.
had the same problem with that Perlscript example.
looks like win cgi is made impossible in 
t.i.defaults.py where it appears to force posix 
and everything else is commented out.

tried adding this to scripts/mktap.py & scripts/twistd.py
and running msys the mingw bash shell

if sys.platform == 'win32':
    if os.getenv('MSYSTEM','nope')=='MINGW32':
        os.path = __import__('posixpath')
which also produces the same error with any cgi

was the same in 1.0.5, currently using 1.0.6 
installed from source with setup.py 
which doesn't create any shortcuts
for tkmktap.py and is missing the twistenv.bat
like the installer created in 1.0.5
woulden't even try to compile c reactor,
otherwise installed ok. 
and, other web activity using html and rpy works.

on another front:
scripts/trial.py won't run from msys
some strange path stuff at the top
causes  ./scripts and ../Lib/site-packages
to be duplicated several times in sys.path and then
ImportError: No module named twisted.scripts.trial

from dos window all the tests try to run

from dos window
$ python trial.py -p twisted.test
protocols\dns.py:50: RuntimeWarning: PyCrypto not available -
   proceeding with non-cryptographically secure random source
$ is too, and I tryed changing a few things,  but ok,
then a bunch of tracebacks
KeyError: Invalid OID 65207c3d20524544 (too large)
Ran 797 tests in 1121.250s

FAILED (failures=5, errors=9, skips=28, expectedFailures=4)
leaves about 150k of junk in scripts/_trial_temp

am I missing something to get cgi working?
in reply please, don't be afraid to state the obvious.

The best thing to hit the internet in years - Juno SpeedBand!
Surf the web up to FIVE TIMES FASTER!
Only $14.95/ month - visit www.juno.com to sign up today!

More information about the Twisted-Python mailing list