[Twisted-Python] DeferredList and errback

Glyph Lefkowitz glyph at twistedmatrix.com
Sun Jul 14 01:45:30 EDT 2002


On Sun, 14 Jul 2002 14:41:18 +1000, Andrew Bennetts <andrew-twisted at puzzling.org> wrote:

> > > - add a flag to the current DeferredList so it can do either behaviour?
> > As I said above, the behavior is really different; the types of the
> > signatures for your callbacks will be different.  That says "different
> > class" to me.

> Would it be so bad to be able to do this:
>     dl = DeferredList([d1, d2, ...], fireOnOneCallback=1, fireOnOneErrback=1)
> 
> This way we can get all four variations for free, without having to think of
> distinct and non-confusing names for them.  Of course, "fireOnOneCallback"
> is a pretty ugly name for a keyword argument.

On second thought, you're right -- I like the way that exact signature looks.
:-).  Go ahead and implement it.


-- 
 |    <`'>    |  Glyph Lefkowitz: Traveling Sorcerer   |
 |   < _/ >   |  Lead Developer,  the Twisted project  |
 |  < ___/ >  |      http://www.twistedmatrix.com      |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://twistedmatrix.com/pipermail/twisted-python/attachments/20020714/23037584/attachment.pgp 


More information about the Twisted-Python mailing list