Changes between Version 21 and Version 22 of CompatibilityPolicy


Ignore:
Timestamp:
09/12/2013 12:51:26 AM (2 years ago)
Author:
rwall
Comment:

link to deprecation helper apis

Legend:

Unmodified
Added
Removed
Modified
  • CompatibilityPolicy

    v21 v22  
    221221Like all changes in Twisted, deprecations must be unit tested.  There are several options for this.  In order of decreasing preference:
    222222
    223     * `twisted.trial.unittest.TestCase.flushWarnings`
    224     * `twisted.trial.unittest.TestCase.assertWarns`
    225     * `twisted.trial.unittest.TestCase.callDeprecated`
     223    * [//documents/current/api/twisted.trial.unittest.SynchronousTestCase.html#flushWarnings `twisted.trial.unittest.TestCase.flushWarnings`]
     224    * [//documents/current/api/twisted.trial._synctest._Assertions.html#assertWarns `twisted.trial.unittest.TestCase.assertWarns`]
     225    * [//documents/current/api/twisted.trial.unittest.SynchronousTestCase.html#callDeprecated `twisted.trial.unittest.TestCase.callDeprecated`]
    226226
    227227=== Weaknesses of the Warnings System ===