Opened 13 years ago

Closed 11 years ago

#959 enhancement closed duplicate (duplicate)

Generate documentation from lore automatically after checkins

Reported by: hypatia Owned by:
Priority: low Milestone:
Component: website Keywords: documentation
Cc: radix, Jean-Paul Calderone, spiv, hypatia Branch:
Author:

Description


Change History (6)

comment:1 Changed 13 years ago by hypatia

Historically, website documentation has only be regenerated at the time of a
release. I believe this was a deliberate choice because sometimes documentation
would describe features not present in the released code base.

Because the documentation has the potential to move much faster than releases,
I'd prefer that the website documentation got updated with new commits.
Documentation of unreleased features or of changed features could proceed on a
branch.

comment:2 Changed 13 years ago by spiv

Also, if documentation of new features was clearly marked "<strong>(new in
2.1)</strong>" or similar, like the Python Standard Library docs do, then new
features wouldn't be an issue for the docs.

comment:3 Changed 13 years ago by hypatia

exarkun's suggestion was to maintain the existing distinction between released
and development docs (are docs even tagged for release? I guess they are) but to
give the development docs a more official status than /users/warner/doc-latest

http://www.livejournal.com/users/jcalderone/6704.html?thread=13104#t13104

comment:4 Changed 13 years ago by Jean-Paul Calderone

The Python doc convention of marking when a feature was introduced is really
useful for other reasons too, although they may all be orthogonal to this
particular issue.

comment:5 Changed 11 years ago by therve

Resolution: duplicate
Status: newclosed

Duplicate of #1140 I think.

comment:6 Changed 7 years ago by <automation>

Owner: radix deleted
Note: See TracTickets for help on using tickets.