Opened 13 years ago

Closed 10 years ago

#914 defect closed duplicate (duplicate)

xmlrpc.QueryFactory failed to catch some exceptions

Reported by: maoy Owned by:
Priority: high Milestone:
Component: web Keywords:
Cc: Jean-Paul Calderone, itamarst, maoy, oubiwann Branch:
Author:

Description


Change History (7)

comment:1 Changed 13 years ago by maoy

[QueryProtocol,client] Traceback (most recent call last):
      File "/usr/lib/python2.3/site-packages/twisted/python/log.py", line 65, in
callWithLogger
        callWithContext({"system": lp}, func, *args, **kw)
      File "/usr/lib/python2.3/site-packages/twisted/python/log.py", line 52, in
callWithContext
        return context.call({ILogContext: newCtx}, func, *args, **kw)
      File "/usr/lib/python2.3/site-packages/twisted/python/context.py", line
43, in callWithContext
        return func(*args,**kw)
      File "/usr/lib/python2.3/site-packages/twisted/internet/default.py", line
535, in _doReadOrWrite
        why = getattr(selectable, method)()
    --- <exception caught here> ---
      File "/usr/lib/python2.3/site-packages/twisted/internet/tcp.py", line 98,
in doRead
        return Connection.doRead(self)
      File "/usr/lib/python2.3/site-packages/twisted/internet/tcp.py", line 239,
in doRead
        data = self.socket.recv(self.bufferSize)
    SSL.SysCallError: (104, 'Connection reset by peer')

2005/03/08 23:27 EST [QueryProtocol,client] Traceback (most recent call last):
      File "/usr/lib/python2.3/site-packages/twisted/application/app.py", line
90, in runReactorWithLogging
        reactor.run()
      File "/usr/lib/python2.3/site-packages/twisted/internet/default.py", line
126, in run
        self.mainLoop()
      File "/usr/lib/python2.3/site-packages/twisted/internet/default.py", line
137, in mainLoop
        self.doIteration(t)
      File "/usr/lib/python2.3/site-packages/twisted/internet/default.py", line
526, in doSelect
        _logrun(selectable, _drdw, selectable, method, dict)
    --- <exception caught here> ---
      File "/usr/lib/python2.3/site-packages/twisted/python/log.py", line 65, in
callWithLogger
        callWithContext({"system": lp}, func, *args, **kw)
      File "/usr/lib/python2.3/site-packages/twisted/python/log.py", line 52, in
callWithContext
        return context.call({ILogContext: newCtx}, func, *args, **kw)
      File "/usr/lib/python2.3/site-packages/twisted/python/context.py", line
43, in callWithContext
        return func(*args,**kw)
      File "/usr/lib/python2.3/site-packages/twisted/internet/default.py", line
549, in _doReadOrWrite
        selectable.connectionLost(f)
      File "/usr/lib/python2.3/site-packages/twisted/internet/tcp.py", line 454,
in connectionLost
        Connection.connectionLost(self, reason)
      File "/usr/lib/python2.3/site-packages/twisted/internet/tcp.py", line 294,
in connectionLost
        protocol.connectionLost(reason)
      File "/usr/lib/python2.3/site-packages/twisted/protocols/http.py", line
361, in connectionLost
        self.handleResponseEnd()
      File "/usr/lib/python2.3/site-packages/twisted/protocols/http.py", line
367, in handleResponseEnd
        self.handleResponse(b)
      File "/usr/lib/python2.3/site-packages/twisted/web/xmlrpc.py", line 271,
in handleResponse
        self.factory.parseResponse(contents)
      File "/usr/lib/python2.3/site-packages/twisted/web/xmlrpc.py", line 296,
in parseResponse
        response = xmlrpclib.loads(contents)
      File "/usr/lib/python2.3/xmlrpclib.py", line 1013, in loads
        p.close()
      File "/usr/lib/python2.3/xmlrpclib.py", line 531, in close
        self._parser.Parse("", 1) # end of data
    xml.parsers.expat.ExpatError: no element found: line 1, column 0

comment:2 Changed 13 years ago by maoy

The direct consequence of this bug is that errback of Proxy.callRemote() doesn't
catch all the exceptions.

comment:3 Changed 12 years ago by Jean-Paul Calderone

Component: web

comment:4 Changed 11 years ago by oubiwann

Cc: oubiwann added

comment:5 Changed 11 years ago by itamarst

Owner: changed from itamarst to oubiwann

Also need to verify whether web2 has same bug.

comment:6 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #872

comment:7 Changed 7 years ago by <automation>

Owner: oubiwann deleted
Note: See TracTickets for help on using tickets.