Opened 8 months ago

Closed 8 months ago

#9123 defect closed duplicate (duplicate)

TLS is imported when not needed.

Reported by: the0id Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

On older Linux distros (like Ubuntu 14.04) installing Twisted with just the conch dependencies will lead to a NO_OP_TLSv1_1 error being thrown when conch is run.

It looks like this is because when the tcp module gets loaded, it tries to load the tls module as well. This is a problem on systems that have an older version of pyOpenssl which don't support TLSv1_1.

A simple work around is updating the pyOpenSSL library, but not importing TLS by default seems to be the more correct way to fix this.

Change History (1)

comment:1 Changed 8 months ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #9121

Note: See TracTickets for help on using tickets.